Vulnerabilidad Crítica en Firewall Barracuda

Noticias, Updates, de Seguridad

@Barracuda NG #Firewall: Remote Command Execution with root Privileges

El día de hoy se publico una vulnerabilidad CRITICA en los Firewall’s de Barracuda, en los cuales se pueden obtener privilegios de Root.

A continuación les dejo el detalle de la Vulnerabilidad:
Security Advisory
—————————————
Vulnerable Software:    Barracuda NG Firewall / phion netfence
Homepage:               http://www.barracudanetworks.com/
Found by:               Wolfgang Neudorfer, Lukas Nothdurfter
Impact:                 Remote Command Execution with root Privileges
Severity:               Critical
Product Description
—————————————
The Barracuda NG Firewall is a family of hardware and virtual appliances designed to protect network infrastructure, improve site-to-site connectivity and simplify administration of network operations. Beyond its powerful network firewall, IPS and VPN technologies, the Barracuda NG Firewall integrates a comprehensive set of next generation firewall technologies, including Layer 7 application control, WAN optimization, Web filtering, anti-virus, anti-spam and network access control enforcement.

[http://www.barracudanetworks.com/ns/products/ng_firewall_overview.php]
Vulnerability Description
—————————————
It is possible to execute an arbitrary command with root privileges on phion netfence 4.0.x, phion netfence < 4.2.15 and NG Firewall < 5.0.2 boxes with activated external authentication scheme (i.e. Active Directory). An attacker with the knowledge of an admin’s username is able to perform arbitrary shell commands during the ssh login procedure on the box. The knowledge of the admin’s password is not required.
Proof-of-Concept
—————————————
A proof-of-concept exploit will not be disclosed due to a responsible disclosure agreement with the vendor.
Severity
—————————————
Because of the high impact and the broad range of vulnerable versions, the severity is considered to be critical.
Vulnerable Versions
—————————————
phion netfence 4.0.x
phion netfence < 4.2.15
NG Firewall < 5.0.2
Patch
—————————————
Hotfix 392_Authentication for netfence 4.0.x
Hotfix 390_Authentication for netfence 4.2.x
Hotfix 391_Authentication for NG Firewall 5.0.x
References
—————————————
www.monkey-cert.at

Esperando que esta información haya sido de gran utilidad.

Saludos de Victor Miranda.

Comparte este Post:

Tags: , , , , , , ,

Professional Ethical Hacker, Pentester & Forensics Investigator MPCS, CEH v8, CSSP, CICP-CICAP HTCIA Member & ISECOM Member Twitter: @victormirandamx

Deja un comentario





September 2017
M T W T F S S
« Sep    
 123
45678910
11121314151617
18192021222324
252627282930  
wordpress visitors